กิมป์/รู้จักกับหน้าต่างในการตกแต่งภาพ Image Window

จาก วิกิตำรา
ไปยังการนำทาง ไปยังการค้นหา

รู้จักกับหน้าต่างในการตกแต่งภาพ Image Window[แก้ไข]

หน้าต่าง Image Window เป็นหน้าต่างที่ใช้ในการตกแต่งภาพ ซึ่งมีส่วนประกอบที่ใช้ในการตกแต่งและคำสั่งต่างๆ ดังต่อไปนี้


Title bar จะอยู่ด้านบนสุดของหน้าต่าง Image Window แสดงรายละเอียดเกี่ยวกับชื่อไฟล์ โหมดภาพ จำนวนเลเยอร์ที่แสดงในภาพ และขนาดภาพ


Image Menu จะอยู่ด้านล่างลงมาจาก Title bar จะเป็นคำสั่งต่างๆ ในการจัดการและตกแต่งภาพ มีคำสั่งทั้งหมด 10 กลุ่มคำสั่ง คือ


  • File จะเป็นคำสั่งเกี่ยวกับไฟล์ทั้งหมด เช่นการเปิดไฟล์ ปิดไฟล์ จัดเก็บไฟล์
  • Edit คำสั่งในการแก้ไขภาพ เช่น การย้อนกลับการทำงาน การคัดลอกภาพ หรือตัดภาพ
  • Select คำสั่งเกี่ยวกับการเลือกพื้นที่ในภาพ
  • View คำสั่งเกี่ยวกับการกำหนดมุมมอง การซูมภาพ
  • Image คำสั่งเกี่ยวกับการจัดการภาพ เช่น การเปลี่ยนโหมดภาพ การกำหนดขนาดภาพ
  • Layer เป็นคำสั่งเกี่ยวกับการจัดการเลเยอร์ เช่น การสร้างเลเยอร์ การคัดลอกเลเยอร์ การลบเลเยอร์
  • Tool เป็นคำสั่งเปิดหน้าต่างเครื่องมือ หรือเลือกเครื่องมือที่ต้องการใช้งาน
  • Dialog เป็นคำสั่งเปิดไดอะล็อก หรือสร้าง Docking ขึ้นมาใช้งาน
  • Filter เป็นคำสั่งเรียกใช้งานฟิลเตอร์ เพื่อนำมาตกแต่งภาพ
  • Script-Fu เป็นคำสั่งเกี่ยวกับการตกแต่งภาพโดยใช้การเขียนสคริปต์


Menu Button เป็นปุ่มเล็กๆ อยู่ตรงมุมด้านบนซ้ายของภาพ เมื่อเราคลิกปุ่ม จะปรากฏเมนูคำสั่งให้เลือกเหมือนกับ Image Menu


Ruler เป็นเป็นแถบไม้บรรทัดทางด้านซ้ายและด้านบนของภาพ ซึ่งเราสามารถ คลิกลากเส้นไกด์จากแถบไม้บรรทัดออกมาวางในภาพ เพื่อใช้งานเส้นไกด์ได้


Quick Mask Toggle เป็นปุ่มเล็กๆ อยู่ตรงมุมด้านด้านล่างซ้ายของภาพ เพื่อเปลี่ยนโหมดภาพให้อยู่ในโหมดควิกมาสก์ สำหรับเลือกพื้นที่ในการตกแต่งภาพ


Pointer Coordinates จะแสดงพิกัดของตำแหน่งที่เม้าส์ชี้อยู่


Unit Menu เป็นแถบแสดงหน่วยวัดที่ใช้กับไม้บรรทัด ซึ่งเราสามารถทำการคลิก เพื่อเปลี่ยนหน่วยวัดให้กับไม้บรรทัดได้


Zoom Button เป็นปุ่มสำหรับกำหนดขนาดมุมมองของภาพ เพื่อย่อ/ขยาย ภาพ


Status Area โดยปกติจะแสดงเลเยอร์ที่ใช้งานอยู่ และขนาดพื้นที่ใช้ของไฟล์ภาพ หากทำการเลือกฟิลเตอร์หรือเลือกคำสั่งแก้ไขภาพแถบ Status Area จะเปลี่ยนเป็นแถบแสดงสถานะการทำงานของคำสั่งนั้น


Navigation Control เป็นปุ่มลูกศรบริเวณมุมขวาด้านล่างของภาพ ใช้ในกรณีที่ภาพมีขนาดใหญ่เกินกว่าที่จะมองเห็นภาพทั้งหมดในหน้าต่างภาพได้ เราสามารถเลื่อนมุมมองภาพไปยังบริเวณที่เราต้องการ


Inactive Padding Area เป็นพื้นที่ว่างในหน้าต่างภาพ แสดงเมื่อภาพมีขนาดเล็กกว่าหน้าต่าง หรือถูกย่อให้มีขนาดเล็กกว่าหน้าต่างเราไม่สามารถจัดการกับภาพในส่วนนี้ได้


Image Display ส่วนแสดงภาพที่เราทำการตกแต่ง แก้ไข


Image Window Resize toggle เป็นปุ่มบริเวณมุมขวาด้านบนของภาพ ปุ่มเปิด หรือปิด (ใช้/ไม่ใช้) ความสามารถในการย่อขยายภาพอัติโนมัติตามขนาดของหน้าต่าง image display ถ้ากดเลือกใช้เมื่อเราย่อขยายหน้าต่าง ภาพจะเปลี่ยนขนาดตาม แต่ถ้าไม่เลือกใช้ (ซึ่งเป็น default) ถึงจะย่อขยาย Image display ภาพจะคงขนาดเดิม

การสร้างไฟล์ใหม่[แก้ไข]

เมื่อเราได้จัดเตรียมภาพที่จะนำมาใช้และได้ร่างชิ้นงานที่จะสร้างเรียบร้อยแล้ว ในหัวข้อนี้เราจะมาสร้างไฟล์ชิ้นงานใหม่กัน เริ่มต้นด้วยการกำหนดขนาดและความละเอียดของชิ้นงานที่จะนำไปใช้งาน ซึ่งเราควรกำหนดให้เหมาะกับลักษณะงาน มีขั้นตอนดังนี้


  1. เลือกคำสั่ง File>New ที่หน้าต่าง Image Windows หรือกดแป้น <Ctrl+N> ที่คีย์บอร์ดเพื่อสร้างไฟล์ใหม่
  2. จะปรากฏหน้าต่าง Create a New Image ขึ้นมา จากนั้นคลิกที่ Advanced Options กำหนดรูปแบบของหน้ากระดาษดังนี้

o Width กำหนดความกว้างของภาพ โดยช่องด้านหลังเป็นการกำหนดหน่วยวัดของความกว้าง ซึ่งมีหน่วยวัดหลายแบบ เช่น pixel เป็นหน่วยวัดพื้นฐานบนคอมพิวเตอร์ หรือ Inches (นิ้ว) และหน่วยวัดอื่นๆ


o Height กำหนดความสูงของภาพ โดยหน่วยวัดจะเป็นไปตามที่เรากำหนดในความกว้าง


o X Resolutionกำหนดความละเอียดของภาพในแนวแกน x โดยงานกราฟิกสำหรับเว็บควรจะกำหนดค่าเท่ากับ 72 pixels/inch และงานด้านสิ่งพิมพ์ต้องใช้ 200-300 pixels/inch


o Y Resolution กำหนดความละเอียดของภาพ ในแนวแกน y โดยงานกราฟิกสำหรับเว็บควรจะกำหนดค่าเท่ากับ 72 pixels/inch และงานด้านสิ่งพิมพ์ต้องใช้ 200-300 pixels/inch


o Color Space กำหนดโหมดสีของภาพ เช่น โหมด RGB จะใช้ในงานกราฟิกสำหรับเว็บและภาพเคลื่อนไหว


o Fill with กำหนดพื้นหลังของภาพ โดยมีรายละเอียดดังนี้


 Foreground Color ปรับให้พื้นหลังเป็นสีโฟว์กราวนด์ที่กำหนดไว้ใน Main Toolbox


 Background Color ปรับให้พื้นหลังเป็นสีแบ็คกราวนด์ที่กำหนดไว้ใน Main Toolbox


 White ปรับให้พื้นหลังเป็นสีขาว


 Transparent กำหนดให้เป็นพื้นโปร่งใส


o Comment เป็นคำอธิบายเกี่ยวกับภาพ


  1. คลิกปุ่ม เพื่อตกลงการสร้างไฟล์ใหม่ตามที่เรากำหนด

ลักษณะพื้นหลังของไฟล์ภาพ[แก้ไข]

กำหนดขนาดไฟล์ภาพตามค่ามาตรฐาน[แก้ไข]

งานกราฟิกที่ต้องทำบ่อยๆ ก็จะมีค่าขนาดของไฟล์งานมาตรฐานที่กำหนดไว้แล้ว เพื่อให้เราเรียกใช้ได้ที่หัวข้อ Template จะมีขนาดและรายละเอียดของชิ้นงานแบบต่างๆ ที่ใช้งานบ่อยให้เราเรียกใช้ได้เลย โดยไม่ต้องกำหนดค่าต่างๆ เอง โดยมีแบบต่างๆ ดังนี้


องค์ประกอบที่มีผลกับไฟล์ภาพ[แก้ไข]

  1. ขนาดความกว้างและความยาว ถ้าภาพมีความกว้างและความยาวมาก ขนาดของไฟล์ก็จะใหญ่มาก ดังนั้นควรจะกำหนดให้ขนาดของภาพมีขนาดตามที่ต้องใช้งานจริง เพื่อช่วยลดขนาดไฟล์
  2. ความละเอียด (Resolution) ถ้าความละเอียดของภาพมาก ขนาดไฟล์ภาพก็จะมาก ถึงแม้คุณภาพของภาพสูงแต่เครื่องคอมพิวเตอร์จะทำงานช้า ดังนั้นเราควรกำหนด Resolution ตามการใช้งาน เช่น

 ภาพที่นำเสนอบนเว็บเพจและพรีเซนเตชั่น ควรใช้ 72 DPI (Dots per inch)


 ภาพที่พิมพ์ออกทางเครื่องพิมพ์เลเซอร์ ควรใช้ 200 DPI


 สิ่งพิมพ์ต่างๆ ที่ต้องเข้าพิมพ์ในโรงพิมพ์ เช่น ปกนิตยสาร ควรใช้ 300 DPI


  1. โหมดสีของภาพ จะมีผลต่อขนาดของไฟล์ โดยสามารถเรียงลำดับโหมดสีที่ทำให้ได้ขนาดไฟล์น้อยไปมาก ได้ดังนี้ Bitmap, Grayscale, RGB, CMYK, Lab color

ทดลองสร้างชิ้นงานโดยนำภาพมาตกแต่ง[แก้ไข]

ในตัวอย่างนี้จะสร้างงานโฆษณาอย่างง่ายๆ โดยนำภาพที่เราเตรียมไว้มาจัดวางให้สวยงาม และจะนำเสนอเป็นหลักการทำงานเบื้องต้นของโปรแกรม GIMP ดังนี้


ขั้นตอนที่ 1 กำหนดขนาดของชิ้นงาน


ขั้นตอนที่ 2 เปิดไฟล์ภาพที่ต้องการนำมาตกแต่ง


ขั้นตอนที่ 3 ตกแต่งภาพโดยการจัดวาง


ขั้นตอนที่ 4 บันทึกไฟล์ภาพ


ขั้นตอนที่ 5 ออกจากการทำงานของโปรแกรม


ขั้นตอนที่ 1 กำหนดขนาดของชิ้นงาน


เริ่มแรกให้เรากำหนดขนาดของแผ่นโฆษณาที่เป็นชิ้นงานของเรา ดังนี้


  1. เลือกคำสั่ง File>New เพื่อเปิดหน้ากระดาษใหม่
  2. จะปรากฏหน้าต่าง Create a New Image จากนั้นกำหนดขนาด และรายละเอียดของหน้ากระดาษโฆษณาของเรา ในที่นี้กำหนด

 ขนาดความกว้าง และความยาวเท่ากับ 640x480 พิกเซล (pixels)


 ความละเอียด (Resolution) 300 พิกเซล/นิ้ว (pixels/inch)


 โหมดสี (Color Space) เป็น RGB Color


 พื้นของภาพ (Fill with) เป็นสีขาว (White)


  1. คลิกเม้าส์ปุ่ม เพื่อสร้างชิ้นงาน

ขั้นตอนที่ 2 เปิดไฟล์ภาพที่ต้องการนำมาตกแต่ง


โดยเปิดไฟล์ภาพที่อยู่ในเครื่องคอมพิวเตอร์ของเรา ขึ้นมาตกแต่งในหน้ากระดาษใหม่ที่เปิดอยู่ จากหน้าต่าง Open Image ดังนี้


  1. เลือกคำสั่ง File>Open เพื่อเปิดหน้าต่างย่อยแสดงภาพ
  2. จะปรากฏหน้าต่าง Open Image
  3. เลือกโฟลเดอร์ที่เก็บภาพ แล้วดับเบิ้ลคลิกภาพที่จะนำมาตกแต่งใน GIMP ซึ่งในตัวอย่างนี้เราจะนำภาพเข้ามาตกแต่งทั้งหมด 3 ภาพ คือ ภาพพื้นหลัง (bg_coffee.jpg), ภาพแก้วกาแฟ (coffee00.gif) และภาพข้อความ (text.tif)

ขั้นตอนที่ 3 ตกแต่งภาพโดยการจัดวาง


ให้นำภาพที่เราเปิดขึ้นมาทั้งหมดจากขั้นตอนที่ผ่านมา นำมาจัดวางในหน้ากระดาษเปล่าๆ ที่ยังเปิดไว้อยู่จากขั้นตอนที่ 1 แล้วทำการจัดวางให้เหมาะสมสวยงาม ดังขั้นตอนต่อไปนี้


  1. เลือกคำสั่ง Edit>Copy หรือกดแป้น <Ctrl+C> ที่คีย์บอร์ดเพื่อคัดลอกไฟล์ภาพพื้นหลัง
  2. ในหน้ากระดาษที่เรากำหนดไว้จากตอนที่ 1 เลือกคำสั่ง Edit>Paste หรือกดแป้น <Ctrl+V> ที่คีย์บอร์ดเพื่อวางไฟล์ภาพที่คัดลอกมา
  3. เลือกคำสั่ง Edit>Copy หรือกดแป้น <Ctrl+C> ที่คีย์บอร์ดเพื่อคัดลอกไฟล์ภาพแก้วกาแฟ แล้วนำไปวางในไฟล์ใหม่ที่สร้างขึ้นตามข้อ 2 เลื่อนตำแหน่งภาพให้อยู่ทางซ้าย ตามตัวอย่าง
  4. เลือกคำสั่ง Edit>Copy หรือกดแป้น <Ctrl+C> ที่คีย์บอร์ดเพื่อคัดลอกไฟล์ข้อความ แล้วนำไปวางในไฟล์ใหม่ที่สร้างขึ้นตามข้อ 2 เลื่อนตำแหน่งข้อความให้อยู่ด้านบนของแก้ว ตามตัวอย่าง
  5. คลิกเม้าส์เลื่อนจัดวางภาพทั้ง 3 ให้เหมาะสมตามที่ต้องการ ก็จะได้ภาพโฆษณาของเราเอง ดังรูป

ขั้นตอนที่ 4 การบันทึกไฟล์ (Save)


หลังจากสร้างชิ้นงานเสร็จแล้ว เราสามารถบันทึกไฟล์ได้หลายรูปแบบ ดังนี้


  1. เลือกคำสั่ง File ที่เมนูบาร์และเลือกรูปแบบการบันทึกไฟล์ดังต่อไปนี้ คือ

• File>Save เป็นการบันทึกงานอยู่ในไฟล์เดิมที่เรากำลังเปิดแก้ไขอยู่


• File>Save As เป็นการบันทึกงานเดิมเป็นชื่อใหม่ หรือบันทึกให้อยู่ในรูปของฟอร์แม็ตใหม่


• File>Save a Copy เป็นการบันทึกงานเดิมเป็นชื่อใหม่ หรือบันทึกให้อยู่ในรูปของฟอร์แม็ตใหม่ คล้ายกับ Save As


• File>Save as Template เป็นการบันทึกงานไว้เป็น Template ให้เลือกใช้ตอนทำการสร้างไฟล์ใหม่ ในหน้าต่าง Create a New Image


  1. ในช่อง ชื่อ : พิมพ์ชื่อไฟล์ที่จะบันทึกลงไป
  2. ในช่อง บันทึกในโฟลเดอร์ : ให้กำหนดตำแหน่งของโฟลเดอร์เพื่อใช้เก็บไฟล์ที่จะบันทึกนี้
  3. โดยปกติไฟล์งานของ Gimp จะเป็นไฟล์นามสกุล .xcf ซึ่งใช้เฉพาะโปรแกรม Gimp เท่านั้น ถ้าต้องการบันทึกในรูปของฟอร์แม็ตใหม่ ให้ทำการคลิกเลือกในช่อง Select File Type เลือกชนิดของไฟล์ที่จะนำไปใช้งาน สำหรับการบันทึกชิ้นงานเพื่อนำไปส่งโรงพิมพ์จะใช้ฟอร์แมต TIFF ส่วนการนำไปสร้างพรีเซนเตชั่นแล้วสร้างเว็บไซต์ จะใช้ฟอร์แมต JPEG, GIF และ PNG
  4. คลิกเม้าส์ที่ปุ่ม เพื่อทำการบันทึกไฟล์

ขั้นตอนที่ 5 ออกจากการทำงานของโปรแกรม


สุดท้าย เมื่อต้องการออกจากหน้าต่างไฟล์ภาพและโปรแกรมการทำงานสามารถทำได้ โดยคลิกที่ปุ่ม ทั้ง 2 หน้าต่างของโปรแกรม GIMP


  1. ที่หน้าต่างแสดงไฟล์ภาพ ในหน้าต่าง Image Window ให้คลิกเม้าส์ที่ปุ่ม ไฟล์จะถูกปิดทันที เมื่อปิดไฟล์งานทั้งหมดจะเหลือหน้าต่าง GNU Image Manipulation Program ซึ่งเราสามารถออกจากโปรแกรมได้โดยคลิกที่ปุ่ม
  2. ที่หน้าต่าง Main Toolbox ให้คลิกเม้าส์ที่ปุ่ม จะเป็นการออกจากโปรแกรมได้เช่นกัน

สารบัญ[แก้ไข]